2008-08-15

Still Alive

Phew. So, back again. “What time do you call this?” you cry.

Woopsi-time has been consumed by other activities of late. First off, there’s the impending university course. This in itself isn’t time consuming (yet), but it does mean I’m expending a lot of brain power finishing off projects at work and handing them over. This leaves me with little incentive to code at home, but the aforementioned university course should afford me plenty of time to finish off Woopsi. Just over a month to go until it starts.

The second barrier to progress is my musical projects. I suddenly found myself playing two instruments in four bands, writing music, and scoring out parts for other instruments. I’ve managed to whittle the bands down to just two, but they still eat up a lot of time. Logic and Sound Studio have quickly proven themselves to be just about the most useful applications I have on my Mac. Logic is probably also the most unhelpfully complex application I’ve ever used, mainly because its functionality is hidden within layers and layers of obscure menus. I can see why Apple can charge ¬£TheEarth for the manual.

Woopsi Update

I post this now partly to assure people that I’m not dead, and partly to note some minor Woopsi updates. The Button, CheckBox, RadioButton and CycleGadget all look different when they are disabled (they draw their text with the darkColour value instead of the standard value). Also, in an attempt at improving the API’s consistency, I’ve renamed the “Textbox” class to “TextBox”. Sync with the SVN repo to get the latest changes, then tear out your hair when you realise that all of your code is broken by a single case change.

Releasing a package with these updates in would probably be a good idea, again to assure people that I’m not dead. And, more importantly (depending on your viewpoint) that the project isn’t dead either.

ALite Update

I pushed this into the SVN repo a while ago but didn’t get around to mentioning it. The released version of ALite (2.1) has a bit of a showstopper bug - you can’t use stored procedures with it. The reason for this is a missing exclamation mark, which I’ve fixed but haven’t released properly yet. Look out for version 2.2 at some point.